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การจัดรูปแบบตัวเลขดวยการกําหนดเอง  (Custom Format) 
 
 ขั้นตอนในการกําหนดรูปแบบ มีดังนี ้
 

1. เลือกพื้นที่ของชองตัวเลขที่ตองการจัดรูปแบบ จากนั้นเลือกคําสั่ง Format > Cells เลือกแท็บ Numer  ที่ชอง 
Category เลือก Custom สามารถเลือกรูปแบบที่ตองการ แลวคลิกปุม OK หรือ คลิกขวาที่ชองขอมูลที่
ตองการ แลว เลือก Format  Cells  จะปรากฏ กลองตัวเลือก ดังรูป 

 

 
 
 

2. หากตองการลบรูปแบบใหเลือกคําสั่ง Format > Cells เลือกแท็บ Numer  ที่ชอง Category เลือก General > 
 คลิกปุม OK หรือ กดแปน Ctrl + Shift + ~ 

 
 
 
 



                                                                                                                             Excel Advanced    - 5 -

                           การกาํหนดรูปแบบใหเปลี่ยนแปลงตามเงื่อนไข (Conditional Formatting) 
 
ตัวอยางเชน จากขอมูล ตองการระบายสีแดงในชอง ขนาดตันกรอส ทีม่ีตัวเลขมากกวา 50 และระบายสีน้ําเงินในชอง
ที่มีขนาดตันกรอสที่นอยกวา 20 มีขั้นตอนดังนี ้

1. เลือกชวงขอมลูที่ตองการกําหนดรูปแบบตามเงื่อนไข  เลือกคําสั่ง Format > Conditional  Formatting 
กําหนดเงื่อนไขแรก ดังรูป 

 
 
 
2. กําหนดเงื่อนไขที่สอง โดยคลิกปุม Add > แลวกําหนดเงือ่นไขที่สอง ดังรูป. 
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3. หากตองการลบรูปแบบที่กําหนดตามเงื่อนไข ใหเลือกพืน้ที่สวนที่ตองการลบไว แลวเลือก คําสั่ง Format > 

Conditional  Formatting จากนั้น คลิก Delete แลวเลือกเงื่อนไขที่ตองการลบดังรูป  แลวคลิก OK 

 
หมายเหตุ 
1. สามารถกําหนดเงื่อนไขไดสูงสุด 3 เงื่อนไข 
2. รูปแบบที่กําหนดดวยคําสั่ง Conditional  Formatting จะมีความสําคญัเหนือกวารูปแบบปกต ิ
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       การควบคุมความถูกตองในการปอนขอมูล (Data Validation) 
เพื่อลดขอผิดพลาดอันเกดิจากการปอนขอมูลจํานวนมาก สามรถกําหนด กฎเกณฑในการปอนขอมูลตางๆไดดังนี ้

1. เลือกพื้นที่ขอเซลลที่ตองการกําหนดกฎเกณฑในการปอนขอมูล แลวเลือกคําสั่ง Data > Validation 
2. คลิกเลือกแท็บ Setting ของกรอบ Data  Validation กําหนดเงื่อนไขจากตัวเลือกตางๆดังนี้ 

 
ความหมายของตัวเลือกตางๆ มีดังนี้ 
Allow คือ เลือกรูปแบบของกฎเกณฑที่ใชในการควบคุมความถูกตองของขอมูล 

• Whole number เลขจํานวนเตม็ 
• Decimal  เลขทศนิยม 
• Date วันที ่
•  Text Length ตัวอักษร 
• Time เวลา 
• List เลือกจากรายการใน drop down list 

Data คือ เลือกเงื่อนไขที่ตองการสรางกฎเกณฑ 
• Between   ระหวาง     
• Not Between ไมอยูระหวาง 
• Equal to  เทากับ    
•  Not equal to ไมเทากับ 
• Greater than มากกวา 
• Less than  นอยกวา 
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• Greater than or  Equal to มากกวา หรือ เทากับ 
• Less than or  Equal to  นอยกวา หรือ เทากับ 

 
3. การกําหนดคําแนะนําในการปอนขอมูล โดยคลิกเลือกแทบ็ Input Message แลวกรอกคําแนะนําที่ตองการ 

 
 

4. กําหนดขอความที่ใชเตือนเมือ่มีการปอนขอมูลผิดพลาดจากฎที่ตั้งไว โดยคลิกเลือกแท็บ Error Alert แลว
กรอกขอความแสดงคําเตือนที่ตองการแลวคลิก OK 

 
5. เมื่อตองการลบ Validation ที่เคยกําหนดไว ใหเลือกเฉพาะพื้นที่ชวงนัน้ไว ใหเลือกคําสั่ง  

Data > Validation >คลิกปุม Delete All > OK 
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        เทคนิคตางๆในการปอนขอมูลลงในชองเซลอยางรวดเร็ว 
 
1. หากตองการเคลื่อนที่ไปยังชองเซลที่อยูขบตางๆของตาราง ใหคลิกเลอืกเซลชองใดชองหนึ่งของตารางไว

กอน จากนั้นใหใชเมาสดับเบิ้ลคลิกที่ขอบของเซล ดังนี้ 
 

ตําแหนงดับเบิล้คลิก ความหมาย 
ดับเบิ้ลคลิกขอบบน เคลื่อนไปชองเซลที่อยูแถวบนสุดของตาราง 
ดับเบิ้ลคลิกขอบลาง เคลื่อนไปชองเซลที่อยูแถวลางสุดของตาราง 
ดับเบิ้ลคลิกขอบซาย เคลื่อนไปชองเซลที่อยูคอลัมนซายสุดของตาราง 
ดับเบิ้ลคลิกขอบขวา เคลื่อนไปชองเซลที่อยูคอลัมนขวาสุดของตาราง 

 
2. หากตองการปอนขอมูลที่ซํ้ากับแถวบน ใหระบายเลือกชองเซลที่อยูใตแถวนั้นแลวกดแปน Ctrl+D 
3. หากตองการปอนขอมูลที่เคยมีอยูแลวในคอลัมนนั้นใหใช  Pick From List  การใช Pick From List   ใหคลิก

เมาสขวาในชองเซลที่กําลังจะปอนขอมูลแลวเลือกคําสัง่ Pick From List   จะมีรายการเลือกปรากฏขึ้นมา  
ดังรูป 

 
 
หมายเหตุ 
1. ไมสามารถใช Pick From List   กับคอลัมนที่เก็บขอมลูชนิดตัวเลขได 
2. ไมสามารถเรียกใชงานขามแถววางได  
3. คียลัดของคําสั่ง Pick  From List    คือ Alt +Down Arrow Key 
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          การปอนขอมูลดวยการใชฟอรม 
  

ในการปอนขอมูลจํานวนมาก การใชฟอรมจะชวยใหงายขึ้น โดยใชฟอรมจะแสดงทีละแถว จดัเรยีงตามแถวใน
แนวตั้ง นอกจากนั้นยังมีคําสั่งชวยในการคนหาขอมูลที่ตองการไดดวย การใชฟอรมมขีั้นตอนดังนี ้

1. เลือกชองเซลชองใดชองหนึ่งในตารางไวกอน 

 
 

2. เลือกคําสั่ง Data > From จะปรากฏฟอรมขึ้นหนาจอ ดังรูป 

 
 

3. ฟอรมจะแสดงขอมูลในแถวแรก โดยมีปุมคําสั่งตางๆอยูดานขวา สรุปการใชงานปุมตางๆดังนี ้
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ปุมคําสั่ง การใชงาน 
New ใชเมื่อตองการเพิ่มขอมูลใหมลงไปในตาราง 
Delete ใชลบขอมูลของแถวที่แสดงอยูบนฟอรมขณะนั้น 
Restore ใชคืนคาขอมูลเดิมกลับมา หากมีกาแกไขขอมูลตางๆบนฟอรมขณะนัน้ 
Find Prev ใชเล่ือนดูขอมลูแถวกอนหนา 
Find Next ใชเล่ือนดูขอมลูของแถวถัดไป 
Criteria ใชกําหนดเงื่อนไขในการคนหา 
Close ใชปดฟอรม 

 
4. หากตองการคนดูขอมูลที่ตองการใหคลิกทีปุ่ม Criteria แลวปอนเงื่อนไขลงในฟอรม แลวคลิกปุม Find 

Next หรือ Find Prev เพื่อเล่ือนดูเฉพาะขอมูลที่ตรงกับเงื่อนไข 
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          การเรียงลําดับขอมูลแบบระดับเดียว 
 การเรียงลําดับขอมูลแบบนี้จะเรียงลําดับโดยใชขอมูลจากคอลัมนใดคอลัมนหนึ่งเปนหลัก ตัวอยางเชน 
ตองการดูขอมูลทะเบียนเรือ โดยเรียงลําดับตามเลขทะเบียนเรือจากนอยไปมาก มีขั้นตอนดังนี ้

1. คลิกเลือกเซลเพียงชองใดชองหนึ่งในคอลัมน ทะเบยีนเรอื เลือกคําสั่ง Data > Sort  เลือก Ascending   
จะปรากฏดังรูป 

 
หรือ  จะเปนการเรียงขอมูลจากนอยไปมาก      

 จะเปนการเรียงขอมูลจากมากไปนอย  
ผลลัพธที่ไดขอมูลจะมีการจดัเรียงใหมโดย สลับท้ังแถว ตามปุมคําสั่งที่คลิก 
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          การเรียงลําดับขอมูลแบบหลายระดับ 
 การเรียงลําดับขอมูลแบบนี้ ใชในการดูขอมลูที่มีความสัมพันธกันในแตละคอลัมน เชน ตองการดูขอมูลการ
ขาย โดยตองการใหเรียงลําดบัจากนอยไปมากตามชื่อพนักงานงานขายเปนหลักและขณะเดียวกนัตองการใหขอมลู
ของพนักงานขายแตละกลุมมีการเรียงลําดบัจากนอยไปมากตามชื่อสินคา เปนตน 
 การเรียงแบบหลายระดับทําได 2 วิธีดังนี ้
วิธีท่ี 1.  เรียงโดยใชปุมคําสั่ง Sort Ascending หรือ Sort Descending บนแถบเครื่องมือ การเรียงแบบนี้ทําไดแคทีละ
คอลัมนเทานั้น แตสามารถใชเรียงลําดับขอมูลไดไมจํากดัระดับ โดยอาศัยหลักการดงันี้ 
 
ใหเรียงลําดับขอมูลจากคอลัมนท่ีมีความสาํคัญต่ําสดุ ไลไปยงัคอลัมนท่ีมีความสําคญัสูงกวาทีละคอลัมนจนครบ 
 
วิธีท่ี 2  เรียงโดยใชคําสั่ง Data > Sort การเรียงวิธีนี้สามารถเรียงไดสูงสุดครั้งละ 3 ระดับ พรอมกนั 
เชน ตองการเรียง ลําดับชื่อเรือ เรียงลําดับตามอักษร จากมากไปนอย ขณะเดียวกนัในแตละกลุมของพนักงานใหเรียง
จากนอยไปมากตามชื่อเจาของเรือ และในกลุมของชื่อเจาของเรือใหเรียงจากนอยไปหามากตามทะเบียนเรือ 
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1. เลือกคําสั่ง Data  >  Sort กําหนดตวัเลือกตางๆดังรูป แลวคลิกปุม OK 
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         การกรองขอมูลดวย AutoFilter 
เมื่อตองการดขูอมูล โดยกรองดูเฉพาะขอมูลที่สนใจวิธีที่งายที่สุดใน Excel คือการใชคําสั่ง Auto Filter ซ่ึงมีขั้นตอน 
ดังตอไปนี ้

1. คลิกเลือกชองเซลใดก็ไดในตารางขอมูล เลือกคําสั่ง Data > Filter>AutoFilter จะเกดิปุม Drop down list 
ขึ้นที่ทายชื่อคอลัมนแตละอนั 

2. เมื่อตองการกรองขอมูลตามเงื่อนไขจากคอลัมน ใหคลิกแลวลือกรายการจาก Drop down list ของ
คอลัมนนั้น  

 
3. หากตองการแสดงขอมูลทั้งหมด ใหคลิกปุม Drop down list ที่เปนสีน้ําเงินอยูแลวเลือก (All) หรือ เลือก

คําสั่ง Data > Filter>Show all 
4. หากตองการกาํหนดเงื่อนไข แลวเลือกตวัเลือก (custom) จากนั้นกําหนดเงื่อนไขที่ตองการจากกรอบ 

Custom AutoFilter โดย กําหนดเงื่อนไขสูงสุดได 2 เงือ่นไข เชนตองการแสดงขอมูลเจาของเรือขึ้นตน
ดวย บ. และ  ลงทายดวย จํากัด 
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5. หากตองการยกเลิกการใช AutoFilter ใหเลือกคําสั่ง Data > Filter>AutoFilter ปุม Drop down list ที่หัว
คอลัมนจะหายไป 

 

การกรองขอมูลดวย Advance Filter 
 การกรองขอมูลดวยการใชคาํสั่ง Auto Filter มีขอจํากัดตรงที่ กําหนดเงือ่นไขในการกรองขอมูล
ของแตละคอลัมน ไดสูงสุดเพียง 2 เงื่อนไขเทานั้น หากตองการกําหนดเงื่อนไขที่มากกวานั้น ตองใชคําสั่ง 
Advance Filter ดังนี ้

1. ใหแทรกแถววางดานบนตารางขอมูลเพื่อสรางพื้นที่สําหรับกําหนดเงื่อนไข แลวคัดลอกคอลัมนที่
ตองการใชเปนเงื่อนไขไปวางไว เชน ตองการสรางเงื่อนไขสําหรับกรองขอมูลเฉพาะชื่อเจาของเรอืที่เปนชื่อ 
บริษัท คือช่ือขึ้นตนดวย บ. และ ลงทายดวย จํากัด หรือ ขึ้นตนดวย บ ใหเตรียมพืน้ที่เงื่อนไขดังรูป  

 
 

2. คลิกเลือกเซลชองใดชองหนึ่งในตาราง แลวเลือกคําสั่ง Data > Filter>Advance Filter กําหนด
ตัวเลือกตางๆในกรอบ แลวคลิก OK 
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ความหมายของตัวเลือกตางๆในกรอบ Advance Filter มีดังนี ้

Filter the list ,in-place แสดงผลลัพธของการกรองในตําแหนงของตารางขอมูล 
Copy to another location แสดงผลลัพธแยกออกไปยงัพื้นที่ใหม โดนกําหนดชอง

เซลเริ่มตน สําหรับการวางขอมูลที่ชอง copy to 
List Range พื้นที่ของตารางขอมูล (โปรแกรมจะกําหนดใหเอง

อัตโนมัติ) 
Criteria Range ช่ือพื้นที่เงื่อนไขที่ไดจดัเตรยีมไว(กําหนดโดยใชเมาส 

ลากระบายพืน้ที่เงื่อนไข) 
Unique record only เลือกใชในกรณีที่ตองการดึงขอมูลจากคอลัมน โดยไม

แสดงคาที่ซํ้ากนัออกมา 
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           การใชคําสั่ง Split 
 
หากตองการดขูอมูลในแผนงานหลายบริเวณพรอมกัน สามารถแบงหนาจอออกเปนหลายๆสวนไดดังนี ้

1. ถาตองการแบงหนาจอออกเปน 2 สวน ซายขวา ใหคลิกเลือกคอลัมนที่ตองการใชเปนแนวเสนไวกอน 
จากนั้นเลือกคาํสั่ง Window > Split 

 
2. ถาตองการแบงหนาจอออกเปน 2 สวน บนลาง ใหคลิกเลือกแถวที่ตองการใชเปนแนวเสนไวกอน จากนั้น

เลือกคําสั่ง Window > Split 
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3. ถาตองการแบงหนาจอออกเปน 4 สวน ใหคลิกเลือกเซล 1 ชอง จากนั้นเลือกคําสั่ง Window > Split 
 

 
 

4. เมื่อตองการยกเลิกการแบงหนาจอ เลือกคําสั่ง Window >Remove  Split 
 
 
 

          การตึงแถว หรือ คอลัมน 
  
การดูขอมูลที่มีพื้นที่กวางๆสามารถตรึงแถวหรือคอลัมนใหอยูกับที่ ในขณะที่สวนอื่นๆยอมใหเล่ือนไปมี
รายละเอียดการทํา ดังตอไปนี้ 
1. ถาตองการตรึงแถวอยางเดียวใหคลิกเลือกแถวนั้นไวกอน จากนัน้ เลือกคําสั่ง Window >Freeze Panes 
2. ถาตองการตรึงคอลัมนอยางเดียวใหคลิกเลือกแถวนัน้ไวกอน จากนั้น เลือกคําสั่ง Window >Freeze Panes 
3. ถาตองการตรึงแถวและคอลมัน พรอมกันใหคลิกเลือกเซล 1 เซล โดยองซายของเซลนั้นอยูตดิกับคอลัมนที่

ตองการตรึง และมีขอบบนตดิกับแถวที่ตองการตรึง จากนั้น เลือกคําสั่ง Window >Freeze Panes 
4. เมื่อตองการยกเลิก ใหเลือก คําสั่ง Window >Unfreeze Panes 
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 การรวมขอมูลตัวเลขจากหลายแผนงานดวยสูตร (  CONSOLIDATE   FORMULA) 
เมื่อตองการนําขอมูลจากแผนงานหนึ่ง มาแสดงอีกแผนงานหนึ่ง ตัวอยางเชน มีขอมูลปริมาณ

นักทองเที่ยวแตละจังหวัดเปนรายเดือน ตองการสรุปออกมาเปนยอดรวมแตละจังหวัดใน 1 ป ไวอีก
แผนงานหนึ่งสามารถทําได ตอไปนี้ 

 
1. แทรกแผนงาน 1 แผนงาน เพื่อใชเปนแผนงานยอดรวม 
2. สรางตารางเพื่อเปนฟอรมตามที่ตองการ 
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3. ในเซลแรกตองการดึงขอมูลจากแผนงานเดือน มกราคม คลิก = แลวคลิกไปยังแผนงาน
เดือนมกราคม คลิกในชองผลรวม ชองแรก ตัวเลขจะปรากฏในแผนงานยอดรวม 
สามารถคัดลอกสูตรตามแถวไดโดย วางเคอรเซอรที่มุมลางขวาของเซลแลวลากตาม
แถวเพื่อคัดลอกสูตร และทําเชนนี้ไปจนถึงเดือนธันวาคม   

 

 
 

4. ในชองรวม ใสสูตรหาผลรวมไดโดยคลิกปุมคําสั่ง   บนแถบเครื่องมือ 
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การเขียนสูตรเพื่อคํานวณคาตางๆ 
1. การหาคารอยละ 

 
 
2. การหาคาอัตราการเปลี่ยนแปลง 
 ตัวอยางเชน ใหหาคาอัตราการเปลี่ยนแปลงของปริมาณผูโดยสารเรอืสาทร-ดาวคะนอง และกําหนดเงื่อนไขถา 
อัตราการเปลี่ยนแปลงใด มีคาลดลงใหกําหนดเปนตวัหนงัสือสีแดง 
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การคํานวณแบบมีเงื่อนไข ดวยฟงกชัน IF 
รูปแบบของฟงกชัน IF := (เงื่อนไข,ผลลัพธเม่ือเปนจริงตามเงื่อนไข,ผลลัพธเม่ือไมเปนจริงตามเงือ่นไข) 
ต.ย. 1 จากขอมูลเรือสินคาดานกระบี่  ตองการเปลี่ยนตวัเลข flag  ถาเปนเลข 1 ใหแสดงเปนเรือเขา  2 แสดงเปน 
เรือออก และเปลี่ยนตัวเลข type ถาเปนเลข 1 ใหแสดงเปนเรือตางประเทศ  2 แสดงเปนเรือคาชายฝง 

 
สรางสูตรในเซลเรือตางประเทศ เรือคาชายฝง ดังรูป 

 
เมื่อคัดลอกสูตรไปยังเซลดานลางจะเปนดงัรูป 
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การคนหาและจัดการกับ Error ตางๆในสูตร 
 การคํานวณบางอยางอาจเกดิ Error ขึ้นไดเชน การคํานวณหาคา อัตราการการเปลี่ยนแปลง ขณะที่ตัวหารเปน
ศูนย ดัง ตวัอยาง 

 

 
 
เมื่อคัดลอกสูตรไปยังเซลดานลางจะเปนดังรูป 
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การแกไขโดยใชฟงกชัน ISERROR ครอบสูตรไวดังนี้    =ISERROR(สูตร) 
ถาสูตรใดใหผลลัพธเปน Error  ฟงกชัน  ISERROR จะใหคาเปน True และถา ไมเกิด Error  ฟงกชัน 
ISERROR จะใหคาเปน False ดังนั้นสามารถสามารถนําเอาฟงกชัน  ISERROR มาซอนใสลงใน
ฟงกชัน IF เพื่อทําหนาที่เปนสวนของเงื่อนไขได จากตัวอยางสามารถแกไขขอความ Error จากตัวหาร
เปนศูนยไดตามขั้นตอน ตอไปนี้ 

1. แทรกฟงกชนั  ISERROR ครอบสูตรเดิมลงไปกอน ดังรูป 
 

 
 

2. คัดลอกสูตรตอลงไปยังชองที่เหลือจะไดผลลัพธ เปน True หรอื False จากนั้นแทรกฟงกชัน IF 
โดยใหฟงกชัน ISERROR เปนสวนของเงื่อนไข ดังรูป 
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3. เมื่อคัดลอกสูตรไปยังเซลดานลางจะเปนดังรูป 
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              การปองกันสูตรและการซอนสูตร 
หากตองการปองกันบริเวณที่มีสูตรอยูทั้งหมดของแผนงานไมใหถูกลบ หรือแกไขได สวนบริเวณอื่นที่ไมมีสูตรสา
มารบลบหรือแกไขไดตามปกติ สามารถทําไดตามขั้นตอนดังนี ้

1. ไปยังแผนงานที่ตองการ กดแปน Ctrl + A เพื่อเลือกทั้งแผนงาน 
2. เลือกคําสั่ง Format > Cell > คลิกเลือกแท็บ Protection ยกเลิกตัวเลือก Locked  และ Hidden ดังรูป แลว

คลิกปุม OK 

 
3. เลือกเฉพาะบริเวณที่มีสูตรโดย F5 > คลิก Special  > เลือกตัวเลือก Formula ดังรูป แลวคลิกปุม OK 

 
4. เลือกคําสั่ง Format  > Cells > คลิกเลือกแท็บ Protection  
เลือก Locked ใหแสดงเครื่องหมายถูก หากตองการปองกันการลบหรอืแกไขสูตร 
เลือก Hidden ใหแสดงเครื่องหมายถูก หากตองการซอนไมใหเห็นสูตรในแถบสูตร แลวคลิกปุม OK 
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5. เปดระบบการปองกันแผนงาน โดยเลือกคาํสั่ง Tools > Protection > Protect Sheet จะมีกรอบขึ้นมา
สําหรับใสรหัสผาน ดังรูป 

 
 
6. ใสรหัสผานที่ตองการลงไปในชอง Password หรือจะไมใสก็ได จากนัน้คลิกปุม OK  ในกรณีใส

รหัสผานจะมกีรอบขึ้นมาใสรหัสผานเปนการยืนยันความถูกตองอีกครั้ง 

 
 

หมายเหตุ 
1. เมื่อตองการแกไขสูตรตองยกเลิกการปองกันกอน โดยเลือก Tools > Protection > Unprotect Sheet 
2. กรณีไมใสรหัสผานในการปองกันไว ผูอ่ืนจะสามารถยกเลิกการปองกันได 
3. กรณีใสรหัสผานในการปองกันไว เมื่อยกเลิกการปองกันจะมีกรอบสําหรับใสรหัสผาน ดังนั้นหากลืม

รหัสผานจะไมสามารถยกเลิกการปองกันได 
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      การใชโปรแกรม Excel สําหรับการวิเคราะหสถิติเบื้องตน 
การใชโปรแกรม Excel สถิติเชิงพรรณา (Descriptive Statistics) 
 สถิติเชิงพรรณา เปนสถิติที่ใชสรุปลักษณะของกลุมขอมูล ซ่ึงขอมูลที่ไดมาจากการเก็บตัวอยางจาก
ประชากรทั้งหมด หรือเก็บจากตัวอยางที่ไดจากการสุมในประชากร ตัวอยางของสถิติเชิงพรรณาเชน จํานวน รอยละ 
คาเฉลี่ย คาเบี่ยงเบนมาตรฐาน หรือแมแตการสรุปในรูปแบบของรูปภาพเพื่อใหงายตอความเขาใจ 
 กอนการใชโปรแกรม ตองมีการติดตั้ง Data Analysis ซ่ึงจะอยูในแถบเครื่องมือ (Tools) ถาเครื่องใดที่ไมมี 
ใหปฏิบัติดังนี้  
 

1. คลิกซายที่เครื่อง Tools แลวเลือกที่ Add-In… 
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2. จะปรากฏหนาตาง Add-Ins ใหคลิกถูกที่ชอง Analysis Tool Pak แลวคลิกที่ OK 
 

 
 
  

การเรียกไฟลขอมูลท่ีตองการวิเคราะหทางสถิติ 
1. นําลูกศรไปคลิกที่ File แลวเลือก Open หรือกด Ctrl+O เลือกไฟลที่ตองการ 
2. จะปรากฏหนาตางดังรูป  
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3. นําลูกศรไปคลิกที่ Tools แลวเลือกที่ Data Analysis… ดังภาพขางลาง 

 
 

 
4. เมื่อปรากฏหนาตาง Data Analysis ใหเลือกที่ Descriptive Statistics จากนั้นใหคลิก OK 

 

 
 
5. เมื่อปรากฏหนาตางดานลาง และปฏิบัติดังตอไปนี้ 

a. Input  
i. Input Range: ใหใสขอมูลที่ตองการวิเคราะห 

ii. Grouped By: ลักษณะการจัดกลุมของขอมูล โดยให คลิก Columns 
iii. Labels in First Row: ใหคลิดถูกถา column แรกของเราเปนคําอธิบายรายละเอียดของ

ขอมูลใน column นั้น 
b. Output Range 
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i. Output Range: ใหคลิกและใสบริเวณที่ตองการใหขอมูลแสดงผล 

ii. New Worksheet Ply: ใหคลิกและใสช่ือ worksheet ที่ตองการใหแสดงผล 
iii. New workbook: ใหคลิกเมื่อตองการใหแสดงผลในชื่อไฟลใหม 
iv. ทําเครื่องหมายถูกในชอง Summary Statistics  

 
6. แลวคลิก OK จะปรากฏตารางสรุปดังภาพ 
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นิยาม ความหมายของคําศัพทตางๆ 
Mean: คามัชฌิมเลขคณิต (Arithmetic mean) คือคาเฉลี่ยของขอมูลทั้งหมด  
Standard Error:  แสดงลักษณะการกระจายตัวของขอมูล คือยิ่งใกลคา O แสดงวากลุมตัวอยางมีการกระจายตัว
ใกลกับคาเฉลี่ยของประชากร 
Median: คามัธยฐาน คือคาของขอมูลที่จุดกึ่งกลางของการกระจายของขอมูลโดย 50% ของขอมูลมีคาสูงกวาคา 
มัธยฐาน และ 50% มีคาต่ํากวาคามัธยฐาน และมักใชในกรณีที่ การกระจายของขอมูลมีลักษณะไมเทากันทั้งสอง
ขาง (Asymmetry) หรือมีลักษณะเบไปทางซายหรือทางขวา 
Mode: คาฐานนิยม คือคาของขอมูลที่มีความถี่มากที่สุดในขอมูลของชุดนั้นๆ ซ่ึงอาจมีมากกวาหนึ่งคาหรือไมมี
เลยก็ได 
Standard Deviation:  สวนเบี่ยงเบนมาตรฐาน เปนการวัดการกระจายของขอมูลวาจะเบี่ยงเบนไปจากคาเฉลี่ย
มากนอยเทาใด 
Sample Variance: คาความแปรปรวน เพื่อสะดวกในการคํานวณและหมดปญหาในเกี่ยวกับเครื่องหมายจึงยก
กําลังสองของคาเบี่ยงเบนของคาเฉลี่ย 
Kurtosis: เปนการวัดลักษณะความโดงของขอมูล 
Skewness: เปนการวัดการกระจายของขอมูลในลักษณะทิศทางของขอมูลวามีความเบไปในทิศทางใด 
Minimum: คาต่ําสุดของขอมูลชุดนั้น 
Maximum: คาสูงสุดของขอมูลชุดนั้น 
Sum: ผลรวมของคาทั้งหมดของขอมูลชุดนั้น 
Count: จํานวนขอมูลทั้งหมด 

 
 
 
 
 
 

  
 



 
 
 
 
 
 
 

 
 
 
 

 
#.03 

 

การสรางรายงานดวย  
Pivot Table 
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        การสรางรายงานดวย Pivot Table 
 Pivot Table เปนความสามารถอยางหนึ่งใน Excel ที่นาสนใจมาก ชวยในการสรางรายงานสรุปผลขอมูล
จํานวนมากๆไดดีและมีความยืดหยุนสูงมากตอการแกไขและปรับเปลี่ยนผลลัพธในรายงานใหไดตามความตองการ
ของรายงานทีส่รางดวย Pivot Table แสดงดังรูป 

 
ขั้นตอนในการสราง Pivot Table 

 1. เปดแฟมขอมูลที่ตองการสรางรายงานดวย Pivot Table คลิกเลือกชองเซลใดก็ไดทีอ่ยูในตารางขอมูล  
ดังรูป 

 



                                                                                                                             Excel Advanced    - 2 -

 
 

1. คลิกเมนู Data > PivotTable and PivotChart Report 

 
 

2.  เลือกชนิดของขอมูลที่จะนํามาสราง เปนรายงานจากกรอบของ Step 1  แลวคลิกปุม Next 
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3.    คลิกปุม Next ของกรอบ  Step 2 ผานไปยงั Step 3 ดังรูป ในกรอบของ Step 3 ใหเลือกตําแหนงที่จะวางไป
ยัง PivotTable ในกรณีที่จะสรางในแผนงานใหม เลือก New Worksheet ถาตองการสรางในแผนงาน
เดียวกันกับขอมูล ใหเลือก Exit Worksheet และกําหนด ช่ือชองเซล เพื่อกําหนดตําแหนงเริ่มตนทีจ่ะวาง 
PivotTable ลงในชองที่อยูใตตัวเลือก Exit Worksheet  คลิกปุม Finish  

 
 

4. จะปรากฏ Layout  ในสวนของ Pivot Table Field List เปนขอมูลแตละคอลัมน ที่เลือกไว 
และ พื้นที่ ในสวนตารางที่สามารถคลิกแลวลากขอมูลจาก Pivot Table Field List มาวางในพื้นทีว่างได ตามแถว 
คอลัมน  
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ตัวอยางเชน ตองการสรางตาราง ที่ประกอบดวย แถวแสดงรายชื่อดานศุลกาการ สวนคอลัมนแสดงวาเปนเรือคา
ตางประเทศ/เรือคาชายฝง และขอมูลที่ตองการแสดงเปนปริมาณสินคา (ตัน) ทําตามขั้นตอนดังนี ้
1.  คลิกลาก ดาน มาวางที่ ในสวน Row  ดังรูป 

 
 

1. คลิกลากเรือ ตปท/ชฝ มาวางในสวนของคอลัมน ดังรูป 

 
 
 



                                                                                                                             Excel Advanced    - 5 -

3. คลิกลากตัน วางในสวนขอมูล ซึ่งจะแสดงผลเปน sum of ตัน  ดังรูป 

 
 

การปรับแตง Pivot Table ใหสวยงามและอานขอมลูไดงาย 
1. เล่ือนเมาสไปวางบน Pivot Table แลวเลือก เมนู Format เลือกคําสั่ง Auto Format ดังรูป ทดลองเลือกรูปแบบ  
แลว คลิกปุม OK  
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2. จะได Pivot Table ในรูปแบบของรายงาน ซ่ึงแสดง Subtotal ของขอมูลแยกกนัแตละกลุมใหดวย ดังรูป 

 
 

การซอนหรอืแสดงขอมลูบางรายการใน Pivot Table 
1.  คลิกปุม Drop down  ที่หัวตารางของ Pivot Table ดังรูป 

 
 
2. รายการใดที่ตองการซอน ใหคลิกกําจดัเครื่องหมายถูกหนารายการนัน้ออก แลวคลิกปุม OK 
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การเรียงลําดับขอมูลใน Pivot Table 
1. ใชเมาสคลิกบน ช่ือฟลดของ Pivot Table ที่ตองการเรียงลําดับขอมูลใหม 
2.     คลิกปุม 

 บนแถบเครื่องมือเพื่อเรียง ขอมูลจากนอยไปมาก      
  บนแถบเครื่องมือเพื่อเรียง ขอมูลจากมากไปนอย  

 
 
 

การเปลี่ยนฟงกชั่นที่ใชมาคํานวณในผลสรุป 
 

1. ใชเมาสดับเบิล้คลิกบนชื่อฟลดที่ใชแสดงขอมูลตัวเลขผลสรุป  

 
 
 
 
 
 
 

 

ดับเบิ้ลคลิก 
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2. เลือกฟงกช่ันในการสรุปผลใหมที่ตองการจากกรอบ Pivot Table Field และสามารถเปลี่ยนชื่อฟลดใหมไดที่
ชอง Name ดังรูป จากนั้น คลิกปุม OK 

 
 

 
จะปรากฏผล ดังรูป 

 
 
 
 
 
 
 
 

เปลี่ยน 
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การแสดงผลสรุปในลักษณะของการเปรียบเทียบ 
ตัวอยางเชน ตองการแสดงขอมูลเปน เปอรเซ็นตเมื่อเทียบกับยอดรวมทั้งหมด มีขั้นตอนดังนี ้

1. ใชเมาส ดับเบิล้ คลิกบนชื่อฟลดที่แสดงขอมูลตัวเลขผลสรุป 
2. คลิกที่ปุม  option จากกรอบ Pivot Table Field จากนั้นเลือกตัวเลือกที่ชอง show data as เปนการ

เปรียบเทียบทีต่องการ เชนเปรียบเทียบจาก ทั้งหมด % of total 

 
3. คลิกปุม OK จะไดขอมูลผลสรุปออกมาดังรูป 
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การซอนบรรทัด หรือ คอลัมน ของ Grand Total 

1. คลิกขวาของเมาสบนคําวา Grand Total ที่ตองการซอน แลวเลือกคําสัง่ Hide ดังรูป 
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การแสดง Grand Total ท่ีถูกซอนไว 
1. คลิกขวาบน Pivot Table เลือกคําสั่ง Table Option 
2. จากกรอบ Pivot Table Option เลือกรายการGrand Total for column หรือ Grand Total for rows ใหใสเครื่องหาถูก 
เพื่อแสดงขอมลูทางแถวหรือคอลัมน ของ Grand Total ตามตองการ ดังรูป 

 
 
การแยกขอมลูดิบในผลสรุปออกมาเปนตาราง 

1. ใชเมาสดับเบิ้ลคลิกบนตัวเลขของขอมูลสรุปที่ตองการแยกดูขอมูลดบิ 

  

ดับเบิ้ลคลิก 
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2. จะไดขอมูลดิบแยกเปนตารางอีกแผนงาน ดังรูป 

 
 
 

การ Refresh ขอมูลใน Pivot Table 
 

 เมื่อมีการแกไขขอมูลในตารางขอมูล Pivot Table ที่สรางไว จะไมเปลี่ยนแปลงขอมูลทันที ถาตองการใหมร
การเปลี่ยนแปลงตองทําการ Refresh ดังนี้ 
1. คลิกขวาบน Pivot Table เลือกคําสั่ง Refresh Data ดังรูป 

 
2.  ถาตองการกําหนดใหมีการ Refresh เองอัตโนมัติตอนเปดแฟมทุกครั้ง ใหคลิกขวาบน Pivot Tableเลือกคําสั่ง 
Table Options 
3. จากกรอบ Pivot Table Options เลือกรายการ Refresh on open ใหแสดงเครื่องหมายถูก ดังรูป แลว คลิกOK 
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การกระจาย Pivot Table ออก เปนหลายตาราง 

1. เปลี่ยน Lay out โดยลากฟลดที่ตองการเลือกดูขอมูลในลักษณะของ Drop down ยายไปในพื้นที่ Page  ตัวอยางเชน 
ตองการดูปริมาณสินคา เลือกดูตามประเภทสินคาแตละอยาง  โดยนําคอลัมนขอมูล สินคาไปวางที่ พื้นที่ของ Page 
ดังรูป 

 
 
2. สามารถเลือก Drop down เพื่อเรียกดูขอมูล สินคาแตละประเภทได 

ลากวาง  
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การสราง Pivot Chart จาก PivotTable 
 1. วางเมาส บน PivotTable ที่ตองการสราง Chart จากนัน้ คลิกขวาเลือกคําสั่ง Pivot Chart ดังรูป 

 
 
2. Pivot Chart จะถูกสรางขึ้นในแผนงานใหม ดังรูป หากตองการเปลี่ยนชนิดของ Chart ใหเลือกเมนู Chart เลือก
คําสั่ง Chart Options  
 

 
 

คลิกเลือก 



 
 
 
 
 
 
 

 
     

 #.04 
 

 
 

การสรางกลองคําสั่งผสมและ
การใชฟงกชัน INDEX 
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     การสรางกลองคําสั่งผสมและการใชฟงกชัน INDEX 

1. ฐานขอมูลท่ีใชในการคนหา  

 ฐานขอมูลที่จะใชเปนตัวอยาง เปนฐานขอมูลของ  ทะเบียนเรือจูง   

  เพื่อใหสะดวกและมกีารจัดการเปนระบบ ควรแยก sheet กัน ระหวาง sheet ที่ใชคนหากับ sheet ที่
เปนขอมูล โดยให sheet ที่ใชคนหาอยูใน shett1 สวน sheet ขอมูลใหบันทึกไวใน sheet2  

2. การจัดการ sheet  

 นําลูกศรไปคลิกที่ File แลวเลือก Open  หรือกด Ctrl+O เลือกไฟลที่ตองการ 

 

 สรางฟอรมการคนหาขอมูล ใน sheet ที่ 1  ดังรูป 
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3. กลองคําสั่งผสม  

 3.1  หลักการและแนวทางในการใช กลองคําสั่งผสมจะใชเปนเครื่องมือที่ใชเรียกตวัเลือกหลัก ใน
ที่นี้จะใช ทะเบียนเรือ เปนคยีหลัก ใหอยูในกลองคําสั่งผสม   เมื่อเลือก ทะเบียนเรือ ขอมูลของ
บุคคลนั้นก็จะปรากฏออกมา  

 3.2 การเรียกใชกลองคําสั่งผสม   ไปที่ มุมมอง(View )/แถบเครื่องมือ(Toolbars)/ฟอรม (Forms)  
หลังจากนัน้จะมแีถบเครื่องมือที่เปนปุมเครื่องมือในการสรางฟอรมเพิ่มขึ้น  
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 3.3 คลิกที่ปุม  ใหเล่ือนเมาสไป นําไปลากและวางใน ฟอรมการคนหาขอมูลในชองเซลล 
ขางลาง เซลล ทะเบียนเรือ โดยใชวิธีการลากและวางตามขนาดที่ตองการ 

  
 3.4 การใสรายการลงในกลองคําสั่งผสม เล่ือนเมาสไปชี้ทีก่ลองคําสั่งผสมที่สรางไว คลิกเมาสปุม
ขวาเลือกคําสั่งจัดรูปแบบตวัควบคุม  
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 3.5 ปรากฏกรอบตอบโตรูปแบบวัตถุ ใหตัง้คาในแถบปอนคาชวงใหไปคลิกเลือก sheet  ขอมูล
ทะเบียนเรือจูง (sheet 2) กดเลือกชวงเซลล ของทะเบียนเรือ  ตั้งคาเชื่อมโยงเซลลโดยใหไปคลิกที่
สวนขวาสุดที่เปนรูป ในแถวเชื่อมโยงเซลล คลิกเลือกเซลลลาง กลองคําสั่ง (sheet1) กดปุมซ้ําอีก
คร้ัง ตั้งคาในสวนของเสน ชีทลงเปน 14  กดปุม ตกลง  
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 3.6  การกําหนดชื่อใหกลองคําสั่งผสม หลังจากไดสรางกลองคําสั่งผสมและนําขอมูลที่เปน
ทะเบียนเรือ มาไวในรายการของกลองดังกลาวแลวก็ใหตั้งชื่อ โดยคลิกเลือกกลองคําสั่งผสม (คลิก
ขวาและตามดวยคลิกซาย)   

    เมนู แทรก(insert) /ชื่อ(name)/กําหนด (define)   จะเกิดกรอบตอบโตที่ช่ือกําหนดชื่อ ที่ช่ือใน
แผนงานใหพิมพคําวา ชื่อ  ลงไป คลิกปุม (ในสวนของอางอิงไปยัง) คลิกเลือก sheet ทะเบียนเรือ 
และเลือกชวงเซลล ขอมูลทั้งหมด กดปุม ซํ้าอีกครั้ง กดปุม ตกลง  

 

 

4. ฟงกชนั INDEX  

เปนฟงกชันทีใ่ชคนหาขอมลูจากฐานขอมลูที่มีอยู โดยการกําหนดตําแหนงของแถวและสดมภของขอมูลที่ตั้งอยู
เปนหลัก รูปแบบของฟงกชันคือ  

=INDEX(ชื่อท่ีตั้งไวจากกลองคําสัง่ผสม,ชวงของเซลลท่ีระบุไวท่ีเปนเลขที่แถว,ลําดบัท่ีของสดมภ)  

สรางฟงกชัน INDEX ในแตละเซลลดังนี้    เชน   F4 =INDEX(ช่ือ,A6,1) 
F6 =INDEX(ช่ือ,A6,2)     F8 =INDEX(ช่ือ,A6,3)   F10 =INDEX(ช่ือ,A6,4)   
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การลบเสนของชีท 

 เลือกเมนู Tools > option  
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 จะปรากฏ หนาตาง ดังรูป คลิก ที่ Gridline เพื่อเลือกใหปรากฏ หรือไมปรากฏ คลิก OK  

 

 จะได sheet ที่ไมปรากฏ เสน gridline  หรือ ไปที่ view > toolsbar> from > toggle grid 
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การใสรูปพื้นหลังตามที่คุณตองการ 

• เลือก Format  > Sheet > Background 

 

• คลิกรูปที่คุณตองการ แลวคลิกแทรก คณุจะไดภาพพื้นหลังที่คุณตองการ 
• จะไดรูปพื้นหลังตามที่คุณตองการ 
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การทํา Hyperlink จาก Excel ไปสู Website ตางๆ 

 กําหนด เซลล เขียนขอความ ที่ตองการ link 

 

 

 เลือก  Insert  > Hyperlink 
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 พิมพช่ือ Web Site ที่ตองการเปด ลงในเอกสารเชน http://www.google.com  คลิก OK  

 

 จะไดเซลลที่สามารถ link ไปยัง website ที่กําหนดได 
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